Jump to content

Issues with triplets when importing MIDIs

Recommended Posts

Hey, so I've been messing around a lot with Maplebeats to make some songs to show off and for the most part it's been going great. One of the first songs I imported, however, sounded a bit off compared to the actual MIDI when i previewed it in program, where notes that should have been the same length were jumping between longer and shorter lengths, removing the flow. I couldn't really figure out why it happened so I moved on to other songs. Now I've figured out how to actually read MML format instead of just copy pasting like i used to so i could edit parts of some songs to make them sound better or to merge channels that didnt need to be separate to save space, and my most recent MIDI i'm working on is doing the exact same thing; Notes that should be the same length are jumping between two lengths, and after looking up the sheet music for the MIDI itself i found out that when importing, Maplebeats is turning triplets into notes of the wrong length. For example, notes that are supposed to have a length value of 24 are alternating between note lengths of 16 and 32. In the end, there is no desync from the other tracks, but it sounds awful regardless. I took a small portion of the song and replaced all the 32 and 16 values with 24, and that did fix the issue, but this song has a LOT of triplets in it and i don't want to have to do this for every individual note, and changing the l value to 24 won't fix the issue because then all the rests between the triplets get fudged and i have to change all of THOSE individually. Is there a setting I'm supposed to check when importing to fix this, or am I just stuck picking out songs that don't use triplets? Thanks anyone who might have some insight on this.

On another smaller note, one of the MIDIs i tried importing uses a tempo of 288, which apparently isnt a valid value in Maplebeats since it exceeds 255, so the song is noticeably slower than it's supposed to be, which isn't that big a problem but still bugs me. Anyone know if there's a way to speed things up past a 255 tempo?

Link to comment

Never really had this issue myself. Are you converting each midi track into separate tracks? Usually that fixes all my issues although I'll have like 5+ 3mle's open at once. As for the 288 tempo... well you're kinda out of luck there unless you can individually shorten all of the notes in which case you're better off writing a new one from scratch

Link to comment

These are my import settings that i've used for all my MIDIs. I do import each track separately as you can see, but this issue will still happen whenever triplets are used in the MIDI.


Also, here is a specific section of the triplets that are giving me problems, highlighted in green. As you can see in the highlighted MML code below, all of these notes are either set to 32 or 16 in length, when ALL of them should have a length of 24. I could change the l value at the start to 24, but as i mentioned earlier, there are several rests between these triplets that would then have to be adjusted individually because they rely on that l value.


Link to comment

Tried your suggestion, now the notes are alternating between 32 and 32-and-a-half lengths, so while it did SOMETHING different, they still aren't the same length. I ended up taking a few hours and fixing all the triplets in the song just to get it done so the song sounds right but it would still be nice to find a solution for this for another song down the road that might use triplets. Thanks for the reply though!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...